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Question

Texts but no calls, intermittently


Hi iD,

Not all the time, but every now and then, (it seems to be about once a week for a few hours) I am unable to make calls. During these periods, my phone allows me to send and receive text messages as normal and I have 4 bars of signal so I know it is not of or related to signal.

With incoming calls, my phone doesn’t even ring and I am told it goes straight to voicemail. With outgoing, it says “connecting” on the screen, before eventually cancelling out.

Other users who have written in with this problem are told that their device is not on the approved list and while that is the case, I do not understand why this is only an intermittent problem? I would expect it to be a constant problem otherwise. I am also new to iD so know this isn’t down to an old/worn SIM card.

I use a Nokia 8000 4G and although it is 4G enabled, I have this switched off because I only use this phone for calls and texts, likewise with the WiFi capability. I am looking to change my handset, but how can I be sure that doing so is going to solve the issue? I am happy to get a phone that is on the approved handset list, however if I do not have 4G or WiFi enabled, is this likely to continue causing problems because there will be no VoLTE or WiFi calling to supplement?

And what, if anything, can you suggest as a remedy to this problem?

Thank you

 

2 replies

Decembersangel72
Silver Contributor
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Hi ​@napqueen 

Have you checked the coverage for your area?
https://www.idmobile.co.uk/help-and-advice/coverage

You HAVE to have 4G (VoLTE) enabled on your phone to be able to make and receive calls using the iD network as 3G has now been turned off in the majority of the areas covered (a very few are left and will be turned off soon, if not already). If you do get a new phone (from the approved list) you WILL have to enable VoLTE for it to be able to connect to the network. Even without VoLTE (4G) enabled you should still be able to use your data and send/receive texts just not calls.
 

Here's a breakdown of potential causes and troubleshooting steps for the problem of intermittent calls:

Potential Causes:

  • Poor Network Signal: Weak or fluctuating signal strength can cause call drops and failures.
  • SIM Card Issues: Damaged, improperly inserted, or faulty SIM cards can lead to call problems. 
  • Call Settings:
    • VoLTE: Voice over LTE (VoLTE) may be required for calls on modern networks, but issues can arise if it's not configured correctly. 
    • Call Forwarding: Check if call forwarding is enabled, which could redirect calls. 
    • Call Barring: Ensure that call barring for incoming calls is not enabled, as this can prevent calls from going through. 
  • Airplane Mode or Do Not Disturb: Ensure these features are disabled, as they prevent both incoming and outgoing calls. 
  • Blocked Numbers: Verify that the number you are trying to call is not on a blocked list. 
  • Software Issues: Though less likely, a software bug could also be causing the issue. 

Troubleshooting Steps:

  1. Check Network Signal: Move to an area with better network coverage.
  2. Restart the Phone: A simple restart can resolve temporary glitches. 
  3. Check SIM Card: Ensure the SIM card is properly inserted and undamaged. Try removing and reinserting it. 
  4. Toggle Airplane Mode: Turn airplane mode on and then off again to reset network connections. 
  5. Check Do Not Disturb: Disable "Do Not Disturb" or "Silent Mode" if active. 
  6. Verify Call Settings:
    • Go to your phone's settings and check call settings related to VoLTE, call forwarding, and call barring. 
    • If using VoLTE, try disabling it to see if it resolves the issue. 
  7. Check Blocked Numbers: Review your blocked numbers list to ensure the number you are trying to call is not blocked. 
  8. Contact your Carrier: If the issue persists, contact your mobile carrier to check for network issues or account-related problems.
  9. Software Update: Check for and install any available software updates for your phone. 
  10. Factory Reset: As a last resort, consider performing a factory reset, but remember to back up your data first. 


It may be worth asking for a replacement SIM as it may be that it has some damage to it (rather than being old/worn) and doing so may solve the problem. Please be aware that the use of your number will be suspended until the new SIM is activated:-

  • Visit any Currys store.

Find your nearest store and head to the ‘Mobile’ section. One of our helpful Tech Experts will issue you a replacement SIM card.

  • Chat to us.

Our Live Chat team are able to issue you a replacement SIM card, which will be sent in the post to the account holder’s address.
Type ‘Talk to a person’ in the dialogue box to connect to an agent.

 

Once you receive your replacement SIM card, you’ll need to activate it. Check out the steps in the article below:

 

Let us know how you get on.





 


Tyler C
iD Mobile Employee
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  • iD Mobile Employee
  • 4725 replies
  • July 6, 2025

Hey there ​@napqueen, unfortunately, the Nokia device mentioned above isn’t supported on our network, so may not work for calls. Please find supported devices below:

 

 

Changing to a device on this list should enable calls to work as normal with our network.

 

Thanks,

Tyler